Sitecore 9.3 installation error- Install-SitecoreConfiguration : The ‘Install-SitecoreConfiguration’ command was found in the module ‘SitecoreInstallFramework’, but the module could not be loaded. For more information, run ‘Import-Module SitecoreInstallFramework’.

Whilst installing Sitecore 9.3 received following error-

 

Install-SitecoreConfiguration -Path .\prerequisites.json
Install-SitecoreConfiguration : The 'Install-SitecoreConfiguration' command was found in the module
'SitecoreInstallFramework', but the module could not be loaded. For more information, run 'Import-Module
SitecoreInstallFramework'.
At line:1 char:1
+ Install-SitecoreConfiguration -Path .\prerequisites.json
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (Install-SitecoreConfiguration:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CouldNotAutoloadMatchingModule

SC93Installation

To resolve this issue, you need to set execution policy to your machine-

Set-ExecutionPolicy -ExecutionPolicy AllSigned

You may also provide a scope to the current powershell session-

Set-ExecutionPolicy -ExecutionPolicy AllSigned -Scope Process

This should help resolve issue and any further powershell script execution process depending on what scope you provide the script to run.

References – Set Execution Policy